- Home


Air Conditioners | Dehumidifiers | Dishwashers | Disposals | Dryers | Freezers | Humidifiers | Ice Makers | Microwave Ovens | Ovens, Ranges, Stoves | Refrigerators | Trash Compactors | Washers | Water Filters

FAQs | Contact | Apprenticeship | Parts | Model Number Help | Newsletter | Beer
- > Do-It-Yourself Appliance Repair Help > The Kitchen Appliance Repair Forum > Touchpad frustration with Kenmore 911.3012990 oven

Find Appliance Parts & Diagrams Here
Enter a model number, part number, type of appliance, brand, or even a part description.

365-day return policy on all parts ordered through this site!


 Moderated by: BrntToast, RegUS_PatOff, appl.tech.29501 Search Our Sites for More Info! Page:    1  2  Next Page Last Page  
New Topic Reply Printer Friendly
Touchpad frustration with Kenmore 911.3012990 oven  Rating:  Rating
AuthorPost
 Posted: Sun Jan 13th, 2008 09:24 pm
  PM Quote Reply
1st Post
caber
Senior Apprentice Appliantologist
 

Joined: Sun Jan 13th, 2008
Location:  
Posts: 15
Flavorite Brew: kona coffee
Status: 
Offline
The specific appliance is a 14-yr old gas wall oven, though not installed until 2000 (long story) and used only occasionally. However, my question probably pertains to most appliance electronic controllers with touchpads. The touchpad up-arrow key has always been a bit uncooperative. But lately it is downright resistant to change. I have identified the clock-oven control and am thinking of replacing it. However, I also wonder if there is any likelihood of an easier fix. In other words, what are the chances that such a glitch is the result of dirt, corrosion or other such stuff which can be corrected? I know that generally electronic parts are just replaced, but if there is an alternative . . .

BTW, the picture of the control unit for this model (item #942797) at the RepairClinic.com site has a different layout than mine. What might that mean?

Back To Top PM Quote Reply  

 Posted: Mon Jan 14th, 2008 08:00 pm
  PM Quote Reply
2nd Post
jambatt
Scholar of Advanced Appliantological Studies


Joined: Thu Jul 12th, 2007
Location: 23 Miles Offshore
Posts: 623
Flavorite Brew: Heiniken
Status: 
Offline
Cut power and open that puppy up.  See the breakdown below. Probably has a broken tab(keyhole shaped tab) on the up arrow tab of the ECC. If tab is broken, no choice but replace ECC. Go to RC and type in the part# for a look see at what the ECC looks like. May need part #260223 also.  Will need to find wiring diagram . If not available, suggest you compare the wire locations on the ECC's before removing any wires so that you can get the wires on the proper pins on the new ECC. Suggest you change one wire at a time and pay attention to the written pin designations.

Attachment: oven.jpg (Downloaded 116 times)



____________________
Don't take life too seriously, none of us get out alive !
Back To Top PM Quote Reply

 Posted: Mon Jan 14th, 2008 11:37 pm
  PM Quote Reply
3rd Post
nlm5858
Senior Apprentice Appliantologist
 

Joined: Mon Jan 14th, 2008
Location:  
Posts: 3
Flavorite Brew: bock beer
Status: 
Offline
Any idea where I might be able to secure a replacement touchpad for a SHAP microwave convection oven Model R-7A82. The part clinic says discontinued.

Thanks.

Back To Top PM Quote Reply  

 Posted: Mon Jan 14th, 2008 11:41 pm
  PM Quote Reply
4th Post
appl.tech.29501
Fellow, Academy of Sublime Masters of Appliantology


Joined: Sun Oct 7th, 2007
Location: South Carolina USA
Posts: 6784
Flavorite Brew: waffle house coffee
Status: 
Offline
Sorry, that touchpad is no longer available :(, time to bite the bullet and getya another microwave.



____________________
If you would like to make a donation you may do so at the link below

http://homepage.mac.com/zenzoidman/appl.tech.29501/
Back To Top PM Quote Reply

 Posted: Tue Jan 15th, 2008 04:51 pm
  PM Quote Reply
5th Post
caber
Senior Apprentice Appliantologist
 

Joined: Sun Jan 13th, 2008
Location:  
Posts: 15
Flavorite Brew: kona coffee
Status: 
Offline
I sent a reply yesterday, but it hasn't shown up. Perhaps my mistake. Anyway, I wanted to thank Jambatt for his helpful and complete reply. I shall pull the unit when I have time and will eventually post an update.

Back To Top PM Quote Reply  

 Posted: Mon Jan 28th, 2008 12:50 am
  PM Quote Reply
6th Post
caber
Senior Apprentice Appliantologist
 

Joined: Sun Jan 13th, 2008
Location:  
Posts: 15
Flavorite Brew: kona coffee
Status: 
Offline
Re: the Kenmore oven Clock-Controller, I finally took the time to pull things apart as per Jambatt's direction. The 3 images below show (Top) the face, (Mid) the back and edge with label showing the GE part # (WB27K5056), and (Bottom) the face peeled back showing the switches. This last one, I think, shows what Jambatt was referring to as keyholes, one just above the UP switch and one below the DOWN switch. In any case, I could find nothing loose or damaged. All the switches have a click to them, including the offending UP switch. So, I still don't know if I have a bad Controller or what . . .

I did try further to determine the right replacement, if needed. Sears shows a newer replacement # WB27K5201R. A1 Appliance shows a replacement #WB27T10327. Neither shows an image. Repair Clinic shows an image (#942797) but the layout is entirely different from mine. I know that doesn't matter if the dimensions are the same and the wiring connects okay. But I don't feel secure in any of the choices.

Any further thoughts?





Attachment: Kenmore.jpg (Downloaded 95 times)

Back To Top PM Quote Reply

 Posted: Mon Jan 28th, 2008 01:52 am
  PM Quote Reply
7th Post
jambatt
Scholar of Advanced Appliantological Studies


Joined: Thu Jul 12th, 2007
Location: 23 Miles Offshore
Posts: 623
Flavorite Brew: Heiniken
Status: 
Offline
Part #942797 at Repair Clinic is a conversion kit. If it doesn't work it can be returned less S/H. May come with instructions but not sure so pay close attention to wire locations. Order from this site(top of page) so Samurai will get credit for order to help finance this forum.

 

http://www.repairclinic.com/referral.asp?R=154&N=942797

Last edited on Thu Feb 7th, 2008 04:18 pm by



____________________
Don't take life too seriously, none of us get out alive !
Back To Top PM Quote Reply  

 Posted: Mon Jan 28th, 2008 08:54 pm
  PM Quote Reply
8th Post
caber
Senior Apprentice Appliantologist
 

Joined: Sun Jan 13th, 2008
Location:  
Posts: 15
Flavorite Brew: kona coffee
Status: 
Offline
Jambatt, am I right in identifying the keyholes in the bottom image of yesterday's post? If so, and I can find nothing broken, then is there any other possibility? If not, could you provide some more detail? Thanks.

Back To Top PM Quote Reply

 Posted: Mon Jan 28th, 2008 11:57 pm
  PM Quote Reply
9th Post
jambatt
Scholar of Advanced Appliantological Studies


Joined: Thu Jul 12th, 2007
Location: 23 Miles Offshore
Posts: 623
Flavorite Brew: Heiniken
Status: 
Offline
Your ECC is different from the one I described. ECC in the link to RC is the one I was talking about. This is the replacement for yours according to RC. Usually one or more of these tabs will break off resulting in the problem you are experiencing. Though your ECC is different, I suspect that the internal workings of the Up arrow has failed with the same results.



____________________
Don't take life too seriously, none of us get out alive !
Back To Top PM Quote Reply  

 Posted: Tue Jan 29th, 2008 03:45 pm
  PM Quote Reply
10th Post
caber
Senior Apprentice Appliantologist
 

Joined: Sun Jan 13th, 2008
Location:  
Posts: 15
Flavorite Brew: kona coffee
Status: 
Offline
Jambatt, thank you. I shall proceed.

Back To Top PM Quote Reply

 Posted: Wed Feb 6th, 2008 09:49 pm
  PM Quote Reply
11th Post
caber
Senior Apprentice Appliantologist
 

Joined: Sun Jan 13th, 2008
Location:  
Posts: 15
Flavorite Brew: kona coffee
Status: 
Offline
The GE part # 942797 has arrived from RepairClinic.com. It fits the housing okay. The wiring, though is a bit vague. I have no trouble with the Grd and Neutral and probably L1 (Light?). However, the rest are not obvious. There was a user's manual with the controller, but no installation instructions. Perhaps with the attached photos (both controllers with contacts shown and lines where it seems appropriate) you can make sense of it. Any hints appreciated.

(BTW, it would really be nice if when I make an error, such as an attachment which is a little too large, that I would not have to start from scratch, that is there is no saved text. I have learned from a couple of bad experiences to save the text to the clipboard prior to previewing. But that shouldn't be necessary. It is not a normal thing to have to do. And I am sure that if I come back in 6 months with another question I won't remember that I have to do it.)

(More BTW, Windows Explorer showed my attached jpg file as 196kb @75dpi, which was fairly sharp. It was rejected as too large. So now I am down to 175kb/55dpi, which is not sharp.)

Attachment: Kenmore Oven WiringX.jpg (Downloaded 72 times)

Back To Top PM Quote Reply  

 Posted: Thu Feb 7th, 2008 01:16 am
  PM Quote Reply
12th Post
appl.tech.29501
Fellow, Academy of Sublime Masters of Appliantology


Joined: Sun Oct 7th, 2007
Location: South Carolina USA
Posts: 6784
Flavorite Brew: waffle house coffee
Status: 
Offline
"Ba" stands for bake and should most likely go on the relay. "L1" is you line voltage. The instructions should point out what wire goes on the "purple dotted relay" If you look really closely at the realy it should have some letters on it like "com" or "BR". It needs to be right before you power it up. I am trying to find a closer image iof the back of the new clock.

oh, I just realized that you had 2 pics in one....the two relay wires on your old clock sould just  transfer over to the new one. 1 is the bake wire and the other is a common...should be inscribed either on the board or the relay.

Last edited on Thu Feb 7th, 2008 01:20 am by appl.tech.29501



____________________
If you would like to make a donation you may do so at the link below

http://homepage.mac.com/zenzoidman/appl.tech.29501/
Back To Top PM Quote Reply

 Posted: Thu Feb 7th, 2008 04:05 pm
  PM Quote Reply
13th Post
caber
Senior Apprentice Appliantologist
 

Joined: Sun Jan 13th, 2008
Location:  
Posts: 15
Flavorite Brew: kona coffee
Status: 
Offline
Thanks, appl.tech.29501. Yes, on the board beside the relay, it does say Broil (purple dot contact) and L1A (the other contact). Now on my old controller, the L1 contact is beside the relay, so I would assume that black wire would on the new controller go to the L1A contact. But then, there is the question of the L1 contact in the upper left corner to the right of the Neutral contact.

If that is so and if the Grd and Neutral are correct, that just leaves the two white wires, presently in a female plug, which I am assuming will go into the new controller's plug (right side), which has 5 wires coming out. So the question is, which wires get connected?

Also, just curious, but are the gas and electric controllers different or do they just carry out the same functions with different fuel sources?

I'll attach a closer view of the new controller.

Attachment: Kenmore new ClockController.jpg (Downloaded 67 times)

Back To Top PM Quote Reply  

 Posted: Thu Feb 7th, 2008 04:17 pm
  PM Quote Reply
14th Post
caber
Senior Apprentice Appliantologist
 

Joined: Sun Jan 13th, 2008
Location:  
Posts: 15
Flavorite Brew: kona coffee
Status: 
Offline
P.S.: I just discovered that the two white wires in the plug are the temp sensors and they are in plug slots 1 & 3. The white wires in the new plug are also separated, though they are slots 4 & 6. But I'd bet they are the ones. However, what are the other 3 wires (yellow, orange & blue) for?

Back To Top PM Quote Reply

 Posted: Thu Feb 7th, 2008 10:04 pm
  PM Quote Reply
15th Post
appl.tech.29501
Fellow, Academy of Sublime Masters of Appliantology


Joined: Sun Oct 7th, 2007
Location: South Carolina USA
Posts: 6784
Flavorite Brew: waffle house coffee
Status: 
Offline
To me this doesn't appear to be the right clock for your application, can you scan and post a copy of your original diagram and a copy of the instructions that came with the clock?

After further investigation the RC part image shows there being a black jumper wire in the kit. To me without having the instructions would lead me to believe that your original black L1 wire would go on the board and the jumper would connect from the board to the relay. Your instructions would really help.



____________________
If you would like to make a donation you may do so at the link below

http://homepage.mac.com/zenzoidman/appl.tech.29501/
Back To Top PM Quote Reply  

 Posted: Thu Feb 7th, 2008 11:04 pm
  PM Quote Reply
16th Post
caber
Senior Apprentice Appliantologist
 

Joined: Sun Jan 13th, 2008
Location:  
Posts: 15
Flavorite Brew: kona coffee
Status: 
Offline
Re: the instructions for the new clock (as I noted above), it came with user instructions, but no install instructions. It is the one that repairclinic.com shows as the replacement and, as above, Jambatt thought it to be the right one. I had reservations, but decided to give it a try.

Yes, there is a 6" black jumper with the kit. However, if one end goes on the relay, there is no other contact for the jumper to go to (that is, if L1, next to Neutral, gets the hot input).

Attached is the wiring diagram for the oven.

Attachment: Kenmore Oven Wiring Diagram.jpg (Downloaded 57 times)

Back To Top PM Quote Reply

 Posted: Thu Feb 7th, 2008 11:47 pm
  PM Quote Reply
17th Post
appl.tech.29501
Fellow, Academy of Sublime Masters of Appliantology


Joined: Sun Oct 7th, 2007
Location: South Carolina USA
Posts: 6784
Flavorite Brew: waffle house coffee
Status: 
Offline
based on that info. I would wire it just as you have it in the picture

neu. to neu.

ground to ground

L1 & orange to the relay

the blue / red / yellow in the harness are not used (for a different model, just cap them off.



____________________
If you would like to make a donation you may do so at the link below

http://homepage.mac.com/zenzoidman/appl.tech.29501/
Back To Top PM Quote Reply  

 Posted: Fri Feb 8th, 2008 06:31 pm
  PM Quote Reply
18th Post
caber
Senior Apprentice Appliantologist
 

Joined: Sun Jan 13th, 2008
Location:  
Posts: 15
Flavorite Brew: kona coffee
Status: 
Offline
Thanks again for your quick response. Okay. Tried that. Saw no activity at all.  So, I switched the hot wire to the L1 contact on the board. Then I had the controller active and could activate switches and see changes on the display. But, when asked to broil, the glow plug did not light up. So no go.  I am thinking about jumpering the hot wire so it can be on both the L1 contact on the board and on the L1A contact on the relay.  What do you think?

Back To Top PM Quote Reply

 Posted: Fri Feb 8th, 2008 11:49 pm
  PM Quote Reply
19th Post
appl.tech.29501
Fellow, Academy of Sublime Masters of Appliantology


Joined: Sun Oct 7th, 2007
Location: South Carolina USA
Posts: 6784
Flavorite Brew: waffle house coffee
Status: 
Offline
Yes, That what I was trying to explain earlier but there must have been some miss communication. No problems, proceed as you described.



____________________
If you would like to make a donation you may do so at the link below

http://homepage.mac.com/zenzoidman/appl.tech.29501/
Back To Top PM Quote Reply  

 Posted: Sat Feb 9th, 2008 09:33 pm
  PM Quote Reply
20th Post
caber
Senior Apprentice Appliantologist
 

Joined: Sun Jan 13th, 2008
Location:  
Posts: 15
Flavorite Brew: kona coffee
Status: 
Offline
Success!  Feeding power to both the relay and the board did it. Thank you so much, appl.tech.29501, for sticking with me. I really did not want to get in too much of a hurry and screw it up. 

Anyway, I tested with bake and broil and temp control. Seems like its right and so much easier on the fingers. BTW, the temp sensor plug (3 slot w/ 2 wires) was of the same family as the new 5-wire plug, so I just plugged it, rather than cutting and splicing. Figured the wiring sequence would probably be right and it was.

I appreciated having the forum available.  Sometime soon I want to get some ideas on replacing the glowplug with a lower power drain one. The thought of using 330 watts all the time I am using my GAS oven is irritating to say the least. But I'll get my thoughts together on that and come back.  Thanks again.

Back To Top PM Quote Reply

Current time is 03:32 pm Tell a friend about this page... all your other friends are doing it! Page:    1  2  Next Page Last Page    
- > Do-It-Yourself Appliance Repair Help > The Kitchen Appliance Repair Forum > Touchpad frustration with Kenmore 911.3012990 oven Top



Find Appliance Parts & Diagrams Here
Enter a model number, part number, type of appliance, brand, or even a part description.

365-day return policy on all parts ordered through this site!

FAQs | Contact | Apprenticeship | Parts | Model Number Help | Newsletter | Beer

Your Sometimes-Lucid Host:
- Home
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly, spilling my steaming entrails onto your floor."


UltraBB 1.17 Copyright © 2007-2008 Data 1 Systems
Page processed in 0.1463 seconds (15% database + 85% PHP). 25 queries executed.

Web Analytics